Saya terus mendapatkan:

SQLSTATE[08006] [7] FATAL: slot koneksi yang tersisa dicadangkan untuk koneksi superuser non-replikasi (SQL: pilih * dari "sheeps" di mana "name" = batas foobar 1)

Jadi saya berpikir untuk mengubah nilai dalam grup paramaeter (default max_connections pada 270)

Tetapi ketika saya mengubah max_connections ke nilai yang lebih tinggi, saya mendapatkan:

"Penyimpanan kesalahan: Tidak dapat mengubah grup parameter default. (Layanan: AmazonRDS; Kode Status: 400; Kode Kesalahan: InvalidParameterValue; ID Permintaan: b5179a68-xxxx-44a8-b396-xxx; Proxy: null)"

Saya memiliki batas maksimal yang ditawarkan Laravel Vapor: 3008 mb.

4
user1469734 20 November 2020, 19:23

1 menjawab

Jawaban Terbaik

Anda tidak dapat mengubah grup parameter default di AWS RDS.

Anda perlu membuat grup parameter khusus, menyetel max_connections di grup itu, lalu melampirkannya ke instance PostgreSQL RDS Anda. Anda kemudian harus memulai ulang instans PostgreSQL RDS agar perubahan diterapkan.

5
Adil B 20 November 2020, 17:31