Saya menginstal di Ubuntu 18.04 oktaf 5.2 menggunakan snap. Sekarang saya memiliki oktaf 5.2. Ada masalah. Jika saya mencoba mencetak gambar (di luar plot) menggunakan

print -dpng figure.png 

Saya mendapatkan pesan kesalahan ini:

warning: print.m: Ghostscript binary is not available. Only eps output is possible

Jika saya menjalankan perintah

which ghostscript

Jawabannya adalah

/usr/bin/ghostscript.

Tolong: bisakah Anda membantu saya?

Terima kasih

0
arkkimede 12 November 2020, 19:28

1 menjawab

Jawaban Terbaik

Tingkatkan ke versi LTS 20.04 saat ini dan instal Oktaf di versi 5.2 yang sama (https://packages.ubuntu. com/focal/octave) melalui manajemen paket normal (bukan snap) menggunakan apt install octave dan sistem manajemen paket secara otomatis menangani dependensi.

1
tardis 14 Desember 2020, 09:12