Beberapa bulan yang lalu saya menggunakan postgres dalam versi 9.5. Saya membuat cadangan basis data (dengan menggunakan pgadmin) dan memulihkan cadangan ini di postgres 9.6 (dengan menggunakan pgadmin juga). Basis data berfungsi dengan baik tetapi ada masalah untuk membuat cadangan dari postgres 9.6 (saat ini ada lebih banyak data daripada beberapa bulan yang lalu).

Saya mencoba melakukannya dengan menggunakan pgadmin tetapi ada kesalahan:

pg_dump: server version: 9.6.16; pg_dump version: 9.5.5 pg_dump: aborting because of server version mismatch

Kemudian saya mencoba membuat cadangan dari baris perintah dengan menggunakan:

pg_dump dbname > dbname-backup.dump

Atau

pg_dump dbname > dbname-backup.sql

Tetapi jika saya menjalankan skrip ini - tidak ada yang terjadi. Tidak ada kesalahan, tidak ada pesan apa pun, cadangan tidak dihasilkan.

Ada windows 10 dan pgadmin 3. Bagaimana mungkin membuat cadangan dari database ini?

0
littlewombat 3 Maret 2020, 21:02

1 menjawab

Jawaban Terbaik

PgAdmin 3 hanya mendukung hingga Postgres 9.5 dan itu sendiri tidak lagi didukung. Anda harus meningkatkan versi ke pgAdmin 4.

1
Schwern 3 Maret 2020, 18:20