Saya menggunakan otentikasi firebase di aplikasi saya. Meskipun saya memanggil Firebase.initializeApp di main saya, itu tidak menerimanya dan memberikan kesalahan ini. Di dependensi pubspec.yaml saya, semuanya mutakhir. Saya tidak tahu di mana saya melakukan kesalahan. Bisakah kamu membantuku?

main.dart

import 'package:firebase_core/firebase_core.dart';
import 'package:widget_catalog/screen/login/login.dart';

void main() async {
  WidgetsFlutterBinding.ensureInitialized();
  await Firebase.initializeApp;
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      debugShowCheckedModeBanner: false,
      home: Login(),
    );
  }
}  ```



**pubspec.yaml**

dependencies:
  provider: ^5.0.0
  intl: ^0.17.0
  table_calendar: ^3.0.0
  syncfusion_flutter_calendar: ^19.1.63
  flutter:
    sdk: flutter
  firebase_core: ^1.2.0
  firebase_auth: ^1.2.0
  cloud_firestore: ^2.2.0
0
sinergy 25 Mei 2021, 22:58

1 menjawab

Jawaban Terbaik

Melompat dari @Frank van Puffelen berkata.

Anda melewatkan () await Firebase.initializeApp. Itu harus await Firebase.initializeApp(). Dan selama Anda memiliki file layanan google yang diimpor dengan benar, Anda akan baik-baik saja!

1
mrgnhnt96 25 Mei 2021, 20:41