Saya menggunakan Android Studio versi 2.3.3. Ini telah diperbarui baru-baru ini. Setiap kali saya mencoba menambahkan ketergantungan baru untuk penggunaan apa pun, mis. recyclerview, cardview, retrofit, dll, gradle gagal menyelesaikannya. Saya telah menyebutkan repositori dalam file gradle. Tapi tidak ada solusi. ini file gradle saya

    apply plugin: 'com.android.application'
    android {
    compileSdkVersion 25
   buildToolsVersion "25.0.3"
defaultConfig {
    applicationId "com.example.apurva.bargraph"
    minSdkVersion 15
    targetSdkVersion 25
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 
       'proguard-rules.pro'
       }
     }
   }

 allprojects {
repositories {
    jcenter()
    maven { url "https://jitpack.io" }
   maven {url "https://maven.google.com"}
  }
 }

 dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
    exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:appcompat-v7:25.3.1'
compile 'com.android.support.constraint:constraint-layout:1.0.2'
compile 'com.android.support:design:25.3.1'
compile 'com.android.support:cardview-v7:25.3.1'
compile 'com.android.support:recyclerview-v7:25.3.1'
compile 'com.github.philjay:mpandroidchart:v3.0.2'
testCompile 'junit:junit:4.12'

 }

Untuk setiap ketergantungan, sinkronisasi gradle gagal dan saya tidak tahu harus berbuat apa lagi. Bantuan apa pun akan sangat bagus.

0
Apurva 7 Oktober 2017, 00:37
Di Android ketika gradle gagal, ini memberi Anda beberapa solusi juga, cukup buka log klik pada opsi, apakah itu memberi Anda kesalahan seperti dependensi dan semua unduhan tidak cocok dan coba lagi. Cukup klik dan lihat apakah itu berhasil
 – 
Alok
7 Oktober 2017, 00:49

2 jawaban

Mungkin ada sejumlah masalah untuk ini
1. Pertama-tama periksa buildToolVersion Anda yang Anda gunakan terinstal di SDK Anda. 2. Anda harus menambahkan kode di bawah ini dalam file gradle proyek bukan di gradle aplikasi.

   maven { url "https://jitpack.io" }
   maven {url "https://maven.google.com"}
  1. Cukup ubah buildToolVersion ke versi yang lebih tinggi yang diinstal di studio Anda.

Ini mungkin membantu Anda.

0
Maraj Hussain 7 Oktober 2017, 02:30
Itu berperilaku dengan cara yang sama untuk versi 26.0.2
 – 
Apurva
7 Oktober 2017, 08:57

Ini karena Anda tidak menginstal pustaka dukungan 25.3.1 di sistem Anda. Jadi, Anda perlu menginstal SDK dari Android Studio melalui Tools->Android->SDK Manager untuk pustaka dukungan di bawah 25.4.0. Anda hanya perlu menggunakan google maven untuk menggunakan pustaka dukungan mulai dari revisi 25.4.0.

0
ישו אוהב אותך 7 Oktober 2017, 05:57
Saya sudah menginstalnya. Dan sebelumnya saya menggunakan 26.0.2 dan jenis kesalahan yang sama terjadi yaitu mengapa saya mundur ke versi ini. Tapi itu juga tidak berhasil
 – 
Apurva
7 Oktober 2017, 08:58
Saya telah menguji aplikasi Anda build.gradle apa adanya, tidak ditemukan kesalahan. Sudahkah Anda memeriksa root build.gradle Anda? Sebagai upaya terakhir, coba File -> Invalidate Caches / Restart...
 – 
ישו אוהב אותך
7 Oktober 2017, 09:14
Saya sudah selesai menggunakan metode cache yang tidak valid. tidak tahu apa yang salah
 – 
Apurva
7 Oktober 2017, 15:12