Saya memiliki pengaturan seperti itu dan semuanya baik-baik saja.
compileSdkVersion 25
buildToolsVersion "23.0.3"
classpath 'com.android.tools.build:gradle:2.2.3'

Setelah meningkat menjadi:
b uildToolsVersion '25.0.0'
classpath 'com.android.tools.build:gradle:2.3.0'
Saya mendapatkan ClassNotFoundException untuk salah satu penyedia saya.
Saya telah mencoba dengan 24.0.3 - masalah yang sama.

P.S. saya tidak dapat membuat compileSdkVersion lebih rendah, karena aplikasi ada di pasar

0
AndrewS 10 Maret 2017, 01:14

2 jawaban

Jawaban Terbaik

Satu-satunya hal yang membantu saya menggunakan perpustakaan terbaru:

public class AppClass extends Application {
//this will initialize multidex in your own Application class
  @Override
  protected void attachBaseContext(Context base) {
      super.attachBaseContext(base);
      MultiDex.install(this);
  }
}
0
AndrewS 31 Maret 2017, 19:18

Anda dapat mencoba dengan baris ini

CompileSdkVersion 23 buildToolsVersion '25.0.0'

-1
Diego Ramirez 9 Maret 2017, 22:16